Installation sous Linux

Mono

Les personnes souhaitant installer un simulateur sous Linux doivent passer par l'installation de mono.

Pour installer mono il y a deux solutions :

  • soit passer par les dépots de sa distribution
  • soit utiliser une version non installée (ce qui permet de changer facilement de version)

Dépots de sa distribution

  • Soit vous restez figé(e) avec la version choisie par les mainteneurs de votre distribution,
  • soit vous installez les dépots officiels afin d'avoir toujours la derniere version mise à jour.

Pour installer les dépots officiels, voir leur page de doc sur le sujet.

Version non installée

Il vous faut pour cela une version déjà compilée (si vous n'en n'avez pas, vous pouvez utiliser une de nos versions Debian disponibles ici )

Pour compiler cette version, nous avons utilisé leur procédure qui se trouve ici.

Nous allons prendre pour exemple la version 5.2.0.215.

  1. Ne pas installer mono
  2. Installer seulement "libgdiplus" par les dépots officiels en utilisant "apt-get install libgdiplus".
  3. Télécharger l'archive et la décompresser dans le dossier /opt ce qui donne /opt/mono-5.2.0.215. ( "tar -zxf mono-5.2.0.215-compiled.tar.gz" )
  4. Faire charger les variables d'environnement pour l'utilisateur exécutant OpenSim.exe (editer le fichier ~/.bashrc de l'utilisateur concerné et mettre en premiere ligne : "source /opt/mono-5.2.0.215/mono-5.2.0.215-venv " ) (ou bien "sourcer" le fichier avant de lancer OpenSim.exe)
  5. Avant de lancer votre simulateur, vérifiez que vous êtes bien sous la bonne version de mono en utilisant "mono --version".
  6. Une fois ceci fait, vous pouvez exécuter votre simulateur avec "mono --server OpenSim.exe"

Si vous changez de version de mono, changez le chemin dans le ~/.bashrc